+1-757-461-3022 x124

Compiling OpenRPT

Before compiling OpenRPT you will need to have the appropriate Qt libraries installed on your system. In addition, OpenRPT currently supports the PostgreSQL and ODBC database connections using Qt's SQL drivers. At this time, if you wish to use a different driver you will have to compile the appropriate Qt drivers and make any changes necessary to OpenRPT to support driver specific code.

To compile OpenRPT you can run the following:

qmakemake

Note: This will compile all the various libraries, components, and tools.

At the time of this writing the following platforms have been tested:

  • Red Hat Enterprise Linux 3 Work Station
  • Red Hat 9
  • Fedora Core 5
  • Windows XP using MSVC6
  • Windows XP using MinGW
  • Mac OS X.3
  • Mac OS X.4

In each of the above cases Qt 4.1.4 and PostgreSQL 8.1.4 were used.

If you have successfully compiled and used OpenRPT on other configurations, and would like to tell us, we would be pleased to hear from you.

up
91 users have voted.